Mike Mayer avatar image
Mike Mayer asked Jeanette F commented

Floor grid confined to 400x400 units?

I wonder if I've accidentally set FlexSim to restrict the floor grid (visible when I select Show Grid) to 400x400 units. I have 21.1.4 and when I start it from scratch and create a new model with all the defaults, the grid is now a 400x400 square with the origin (0,0,0) in the center. The floor grid used to go into infinity. Now, when I pan, rotate, and zoom, it does so within this 400x400 square. The problem is that as I add things and the model grows larger, it goes beyond the restricted grid's edges, where there is no grid (because it stops). Did I somehow turn on a "restrict grid" feature? Or, does the grid no longer go into infinity in 21.1.4? How can I make the grid extend into infinity, like it did in earlier versions?

It seems like a setting but I can't find it.

Thanks to all.

FlexSim 21.1.4
floor grid400 x 400grid restriction
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

1 Answer

Jeanette F avatar image
Jeanette F answered Jeanette F commented

Hello @Mike Mayer,

Go to Global Preferences and select the Auto-expand grid in ortho and perspective views.



Please, let me know if this doesn't work.

1625253812341.png (25.8 KiB)
1625253832168.png (34.4 KiB)
· 5
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Mike Mayer avatar image Mike Mayer commented ·

Perfect Jeanette, worked like a charm! Thank you! Sorry for my late reply - I was out of office until today.

As I was poking around in the Global Preferences / Environment tab last week, I simply missed that option, which of course was un-checked (therefore limiting the grid to 400x400).

I hit the User Manual to find out more about the auto-expand grid feature, and the screenshot in the manual shows that option "checked", so I can probably assume that's the default in FlexSim. I only noticed it when I deleted my AutoCAD floor in preparation for reusing my model with a different floor drawing.

I suspect that at some point I did disable that auto-expand and forgot about it. Of course in hindsight, the better thing would have been for me to simply un-check "Show Grid" in the View properties (rather than un-checking Auto-expand grid).

If we do decide to disable the auto expand grid in the future, for a particular model, is there a way to specify the limits? I measured 400x400 units when I was looking into it, and that seems to be the default grid size with a new model.

For example if I have a simulation model that occupies a smaller area of a larger plant (like a repair shop 30M x 15M in the middle of a larger 200M x 100M factory). Can I have the grid be 30x15 when auto-expand grid is disabled? That might be a nice way to define the edges of a model, and at the same time give a convenient way of laying things out, as if the floor had tape lines every meter.

So, I might have a 200M x 100M AutoCAD drawing of the whole factory as a Model Background, positioned such that a smaller 30x15 meter FlexSim grid aligns atop the AutoCAD drawing at the location where we are planning a repair shop. I could even drop the Model Background AutoCAD plane by something small like -0.01 in the Z direction to guarantee that the FlexSim grid is always visible (i.e. slightly above it, at 0.0 in Z).

Thanks again,


0 Likes 0 ·
Jeanette F avatar image Jeanette F ♦♦ Mike Mayer commented ·

Hello @Mike Mayer,

One of the developers informed me that the grid view of 400x400 is hard coded.

0 Likes 0 ·
Mike Mayer avatar image Mike Mayer commented ·

Ooops Jeannette sorry, I should probably have added my reply as a Comment (here) instead of an actual Answer below. By the way, there is a survey email shortly following the FlexSim Answers interaction. I first took the survey a while ago (a few months back) when it first came out, but whenever it comes up each time I interact with FlexSim support, it says I've taken it already.


It's probably set in a cookie somewhere.

No biggie - you guys give great technical support (and have for years) and that's what matters.

0 Likes 0 ·
1625663459129.png (10.7 KiB)
1625663470050.png (10.7 KiB)
Markus Cueva avatar image Markus Cueva ♦ Mike Mayer commented ·
Sorry, Mike! I've changed the survey to allow responses across multiple survey invitations. Thanks for letting us know!
0 Likes 0 ·
Mike Mayer avatar image Mike Mayer Markus Cueva ♦ commented ·
Hello Markus! Thanks for the survey fix.


0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.