Rahul R avatar image
Rahul R asked Jason Lightfoot commented

Find item based on a label on storageObject of the item

How do I find an item based on a label "Type" on the storageObject (Racks, Floor storage) in the model.

I tried using find item activity in the process flow with the query as follows:


I get an exception that looks like the query tried to access Type on an object that is not a storageObject. Is there anything wrong with the query or my approach?


Other approach I have is to label items and use item label to identify them.

FlexSim 22.2.4
storage systemfinditem
1678382196313.png (28.6 KiB)
1678382744808.png (11.7 KiB)
· 4
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Joerg Vogel avatar image Joerg Vogel commented ·
I assume, you have stored pallets in a rack. Each pallet stores several items, Those have labels and one of them is Type. Unfortunately the warehouse knows only the pallets while searching an item, because item is only a keyword, which references the first subnode level of a slot to identify slotitems. Please don't make a mistake to mismatch keywords with actual references to items in subnodes of a tree like structure.
1 Like 1 ·
Kavika F avatar image Kavika F ♦ commented ·

Hi @Rahul R,

It's hard to know how to help without looking at your model. To receive a more accurate solution, please post your model or a sample model that demonstrates your question.

Proprietary models can be posted as a private question visible only to FlexSim U.S. support staff. You can also contact your local FlexSim distributor for phone or email help.

If you can't post your model, then some more details about your list would be helpful.

Upon first look at your Query, I'm a little skeptical of using item.slot.storageObject.Type in your Query. What does item refer to? Is that a column name, a label, etc.?

Generally, you'd put a ColumnName for the query to look for the token.Type.

WHERE ColumnName = $1.Type
0 Likes 0 ·
Rahul R avatar image Rahul R Kavika F ♦ commented ·
@Kavika F : Thank you, I will post as a private question as I am unable to reproduce the issue on a smaller problem. I was trying to refer to the items in the storage system (similar to value in the list). As you said, that reference could be incorrect.
0 Likes 0 ·
Jeanette F avatar image Jeanette F ♦♦ Rahul R commented ·
Hello @Rahul R ,

You can edit this question to be a private question and attach your model to it.
0 Likes 0 ·

1 Answer

Rahul R avatar image
1 Like"
Rahul R answered Jason Lightfoot commented

Thank you!

I will close this question, I was able to get to desired behavior using list (instead of querying storage system).

· 3
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Joerg Vogel avatar image Joerg Vogel commented ·

@Rahul R, Too late, here is an approach directly in Finditem activity: findItem2022_1.fsm.

findItem quere here is:

WHERE item.item.up.Type = $1.Type

findItem query works, too:

WHERE item.storageItem.currentSlot.storageObject.Type = $1.Type
0 Likes 0 ·
finditem2022-1.fsm (48.2 KiB)
Jason Lightfoot avatar image Jason Lightfoot ♦ Joerg Vogel commented ·

I think the item.item syntax will unvirtualize all items - so if you're using that feature, this would not be a good option.

1 Like 1 ·
Rahul R avatar image Rahul R Joerg Vogel commented ·

Thank you Joerg! Appreciate you looking at it again!

0 Likes 0 ·