question

Patrick Zweekhorst avatar image
0 Likes"
Patrick Zweekhorst asked Patrick Zweekhorst commented

AGV throwing exception when loading item

Hi,

A customer of ours created a model, but it gives a strange exception at time 0. The train AGV just needs to pick up 2 wagons without traveling, but FlexSim throws an error. The strange thing is that the model I created does work. We can’t find the difference why it is working in one model and it isn’t working in the other model. Could someone check what is causing the problem?

Thank you in advance.

Patrick

ModelBaseCase_1g_Not working.fsm

ModelBaseCase_1g_Working.fsm

FlexSim 22.2.2
agvstrain
· 5
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Jason Lightfoot avatar image Jason Lightfoot ♦ commented ·
It looks like something to do with offset travel - if that's disabled on the non-working model it operates correctly. Should these AGVs be set to use offset travel?
0 Likes 0 ·
Patrick Zweekhorst avatar image Patrick Zweekhorst Jason Lightfoot ♦ commented ·
@Jason Lightfoot , thank you for looking into. This indeed could be related, but the strange is that is does work with "Use offset travel" in the working model. So, I guess that that should not be the actual problem. Later on in the model the AGV will need to do some offset travel, so it would be good if that would work.
0 Likes 0 ·
Jason Lightfoot avatar image Jason Lightfoot ♦ Patrick Zweekhorst commented ·

Understood. Yes I reached the same conclusion, so we probably need a developer to take a look.

1 Like 1 ·
Show more comments
Patrick Zweekhorst avatar image Patrick Zweekhorst commented ·

@Jordan Johnson ,

Do you know if this is a bug we can fix or that it is something for the dev list ?
Thank you in advance.

0 Likes 0 ·

0 Answers