Rara Hasna avatar image
Rara Hasna asked Jeanette F commented

Parameters, group of objects, more than 1 output ports

Hello, on this model below I try to group an operator, processor, and queue in Plane 1 (reference:

The Processor itself processes all items and then separate them to 2 Output Ports by Item Types (I use Output > Send to Port > Port by Case):1706528470273.png

I already set the Plane as a Group and used it for parameters, but the problem is if I set the parameter value to 2, the item that went to Processor1_2 got blocked and couldn't send the item to Output Ports. If I see the Output Ports, the processor suddenly adds another blank output port as the first output port. I tried to delete it but every time I re-run it the blank output port just added by itself.


Can you tell me what's wrong with the model and help me to fix it? Thank you very much.

experimenter plane.fsm

FlexSim 22.2.0
groupsplaneoutput portparameter
1706528456511.png (368.8 KiB)
· 4
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Felix Möhlmann avatar image Felix Möhlmann commented ·

Looks like a bug to me. Copying the plane breaks one of the connections to the processor.

You can work around it by deleting the output connections of the copied processor in the parameter's "On Set" code before the new plane is connected to the 'outside objects' again. See line 28 below.


0 Likes 0 ·
1706531898020.png (11.5 KiB)
Rara Hasna avatar image Rara Hasna Felix Möhlmann commented ·

Hi, thank you for replying. I tried to delete the Output Ports on the copied Processor and follow your instruction to write the "On Set" code but it didn't change anything. Am I doing it right?1706533404341.png

0 Likes 0 ·
1706533404341.png (305.0 KiB)
Felix Möhlmann avatar image Felix Möhlmann Rara Hasna commented ·
Looks correct. In one test I also had problems getting it to work right away. Try deleting the second plane manually and/or setting the parameter to something other than 2 after you applied the changes to the code.
0 Likes 0 ·
Jeanette F avatar image Jeanette F ♦♦ commented ·

Hi @Rara Hasna, was Jason Lightfoot's answer helpful? If so, please click the "Accept" button at the bottom of their answer. Or if you still have questions, add a comment and we'll continue the conversation.

If we haven't heard back from you within 3 business days we'll auto-accept an answer, but you can always comment back to reopen your question.

0 Likes 0 ·

1 Answer

Jason Lightfoot avatar image
Jason Lightfoot answered

As Felix say's, this does look like a bug - thanks for pointing it out. I'll send it to the developer team.

5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.