question

Farah_najihah A avatar image
0 Likes"
Farah_najihah A asked Kavika F commented

Exception error caught, how to tackle? whats the problem?

Hi, I need help on my model, how to tackle this kind of error? I work just fine at night, then suddenly all this error appear when I reopen it in the morning. I attached the model file together for your reference. Sometimes, when I was editing my model, some error appear repeatedly I need to force close without saving then only it okay. Why? Thank you in advance!


exception: Exception caught in TreeNode::receivemessage()

exception: EditorSpatial::drawContent()

exception: Exception Caught in ObjectFunction232__project_library_FlexSimEventHandler_behaviour_eventfunctions_OnDraw object: /ConveyorSystem i: /ConveyorSystem class: /ConveyorSystem



Model 1.fsm

exception errortreenodereceivemessageeditorspatialobjectfunction
model-1.fsm (7.5 MiB)
· 1
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Hi @Farah_najihah A,

We haven't heard back from you. Were you able to solve your problem? If so, please add and accept an answer to let others know the solution. Or please respond to the previous comment so that we can continue to help you.

If we don't hear back in the next 3 business days, we'll assume you were able to solve your problem and we'll close this case in our tracker. You can always comment back at any time to reopen your question, or you can contact your local FlexSim distributor for phone or email help.

0 Likes 0 ·

1 Answer

·
David Chan avatar image
0 Likes"
David Chan answered Kavika F commented

model-1_DC.fsm

@Farah_najihah A

Managed to fix the model for you. Try out to see if it works


David


model-1-dc.fsm (7.0 MiB)
· 4
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

@David Chan, thank you for your help, unfortunately it does not work. Still got the same error :( when I open it appears black screen, then I open default workspace, all the errors come out. maybe is it related to my laptop specs?
0 Likes 0 ·
Kavika F avatar image Kavika F ♦ Farah_najihah A ·

Hey @Farah_najihah A, here are the minimum system requirements for FlexSim. I don't think it's related to your specs though.


I tried opening your model and got similar results - a black screen on startup and then errors when trying to reopen it. I was able to get to a state where I could run your model, but on exiting the program and restarting it, I got the black screen again. I zoomed in on the only part of the system I could see (BlowMoulder1) and let it sit. After a minute or two, everything else loaded in (except for a few Racks) and it could run.


I think that due to some of the errors in your earlier iterations you talked about, they may have corrupted the file you're working with. Have you tried recreating the model in a new file recently and gotten similar results? What were some of those earlier errors? They all seemed to revolve around the ConveyorSystem.

0 Likes 0 ·
Hi @Kavika F, my laptop requirements all met. specs are fine.


I did achieve the same where I could open the file but without the conveyors loaded. Then, when I reopen, it appear black again. Not sure about the error, this is my first time using Flexsim, I have not tried working the same model again, maybe will try that.

0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.