question

Jarod P avatar image
0 Likes"
Jarod P asked Jarod P commented

Excel Import Issue since upgrading to Flexsim 2022 Update 1

Ever since i have updated to FlexSim 2022.1.0 i have been having an issue importing excel files into global tables. I thought perhaps it was an issue with .1.0 so i installed .2.0 but am having the same issue. I have encountered it on models that were very large so i chalked it up to me making some mistake in the model so i worked around it on that model. Today i started creating a brand new model, i dont even have a Process Flow started and im getting this error. U71x Spoiler.fsm

1665517922422.png

FlexSim 22.2.1
excel importimport2022
1665517922422.png (62.0 KiB)
u71x-spoiler.fsm (296.9 KiB)
· 6
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Ben Wilson avatar image Ben Wilson ♦♦ commented ·

@Jarod P do you still have an older version of FlexSim installed that you could test? My hunch is that the issue may actually be on the Windows/Excel side, and you'd find the issue even in an older version of FlexSim where you know your Excel import had previously worked.

Many of our users encounter Excel issues after Office updates. From Phil's answer:

"The problem is an issue with how Excel is registered as a COM application with Windows. It is usually fixed by uninstalling and reinstalling Excel."

In his answer Phil goes into the details about how these issues stem from Microsoft code out of our control. Luckily, as Phil mentions, many of our users are able to clear up Excel launch issues with a simple uninstall/reinstall of Office. My answer here links to resources for a deep uninstall of Office, if that is necessary.

0 Likes 0 ·
Jarod P avatar image Jarod P Ben Wilson ♦♦ commented ·
2022.0.0 is the oldest version i have on my computer at this time, when i updated to it i cleared out all the previous versions. I will get with my IT to have the excel reinstalled.
0 Likes 0 ·
Jason Lightfoot avatar image Jason Lightfoot ♦ Jarod P commented ·
You could also try an Office repair to see if that helps.
0 Likes 0 ·
Show more comments

1 Answer

Jeanette F avatar image
0 Likes"
Jeanette F answered Jarod P commented

Hello @Jarod P,

I created a test excel file to load into your Global Table and it had no problems loading it in.

Could you send in an excel file that has this issue occur? From what I could find from past posts there was an occurrence when this error was thrown it did turn out to be a bug. However often with excel issues, repairing or reinstalling excel has solved issues. If you could send us a file that has issues we could more easily analyze if its a bug in FlexSim or if your excel is in need of repair.

· 3
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Jarod P avatar image Jarod P commented ·

71x Spoiler Schedule.xlsx

This is the sheet I had been trying to upload.

0 Likes 0 ·
Jeanette F avatar image Jeanette F ♦♦ Jarod P commented ·

Hello @Jarod P,

I never had an error throw. I was able to load sheet2 with no issues. However I did have trouble with Sheet1. The fix was to put a name in the first row and column that was originally blank.

I don't know if this will be a fix for you considering I never did see the error. Can you let us know if the problem persists?

0 Likes 0 ·
Jarod P avatar image Jarod P Jeanette F ♦♦ commented ·
I added info to the A1 placeholder and it imported just fine as well.
0 Likes 0 ·