mcretssinc avatar image
mcretssinc asked Felix Möhlmann commented

Custom States in MTBF MTBR

Hello guys,

How is it possible to exclude custom states from being affected by the MTTR MTBF ?

My custom states don't appear on the left side.


Thank you.

FlexSim 24.1.0
mtbf mttr
1720470864737.png (45.5 KiB)
· 3
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Joerg Vogel avatar image Joerg Vogel commented ·
States in general are discrete number values. You translate them as string information. States for 50 values are predefined. And if you don’t find your values in a GUI, you still can find them in the tree. Try it.
0 Likes 0 ·
Felix Möhlmann avatar image Felix Möhlmann commented ·

Can you upload your model or an example model with the object with custom states so we can check why they don't appear in the list?

As a workaround you can edit which states the MTBF applies to directly in the tree. (Add a least one state to the right side for this node structure to appear. Then edit it to your liking. As far as I can tell the naming of the nodes does not matter, only the values which represent the state numbers of the affected states)


0 Likes 0 ·
1720507788136.png (16.5 KiB)
mcretssinc avatar image mcretssinc Felix Möhlmann commented ·

Hello guys,

I have uploaded the model. When running with just 1 resource the state pie chart registers only the wanted states but the Gantt registers also travel empty and travel loaded. When running with 2 resources both charts register travel empty and travel loaded.

The important thing is that MTBR/MTTR should take into consideration only travel empty/loaded states and not other states. But somehow it triggers even if I set different states to the task executers other than travel empty/travel loaded.

How can I fix this ?

Thank you so much.

State_test_model.fsm1 task_executer.jpg2 task_executers.jpg

0 Likes 0 ·
1-task-executer.jpg (583.7 KiB)
2-task-executers.jpg (622.5 KiB)
state-test-model.fsm (162.7 KiB)

1 Answer

Felix Möhlmann avatar image
Felix Möhlmann answered Felix Möhlmann commented

The state pie chart filters out states with a time of 0 automatically.


The gantt chart does not have this option. So you will always see all states the object entered appear in the legend. Even if the object never spends any actual time >0 in the state. A possible workaround would be to install the chart components and clone the Statistics Collector with a Calculated Table while filtering out any entries where the start time and end time are equal. Then use the Calculated Table as input for the chart.

In your Process Flow you always set the state of TaskExecuter1, not the currently acquired resource. So any TEs past the first will always be in the default states.


· 2
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

mcretssinc avatar image mcretssinc commented ·
Hello @Felix Möhlmann ,

Even so the task executers they still go through travel empty/travel loaded states. Is there a way to fix that ?

0 Likes 0 ·
Felix Möhlmann avatar image Felix Möhlmann mcretssinc commented ·

No, the default state change will always occur. You can force the TE into a different state afterwards, as you currently do, but not prevent the state switch. Though if the state is only assumed for 0s it should not make any difference as far as model functionality is concerned.

If you want full control over the state implement a custom state profile in addition to the default one. There are multiple posts on this forum that demonstrate how this is done.

0 Likes 0 ·