Kritsadakorn K avatar image
Kritsadakorn K asked Felix Möhlmann commented

What if I want 2 AGVs not to overlap?


route characteristics in the model is the same route with the running of all 3 AGV vehicles

What should I do if I want the AGV car to not run over each other? or there is a stop and wait for the car in front first.

(The route is a circular run.)

FlexSim 23.0.1
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

1 Answer

Felix Möhlmann avatar image
1 Like"
Felix Möhlmann answered Felix Möhlmann commented

Set the type of the connection to Non-passing and set the Spacing value appropriately for the desired minimum distance between the task executers (in the network node properties, the connection type can also be changed by dragging the connection between the nodes again).

The non-passing connection is marked by a yellow arrow.


Additionally, if you don't want more than one task executer to occupy a network node at a time, set the Max Travelers to 1 and set the task executers to Do not travel offsets and block space on networks.


capture1.png (20.7 KiB)
capture2.png (4.5 KiB)
· 4
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Kritsadakorn K avatar image Kritsadakorn K commented ·

Thank you for replying to my question.

I've made an effort to repair it by using the advice in the answer. However, the issue is still present. Within the route, the car crosses over. What do I need to fix and where?

0 Likes 0 ·
Felix Möhlmann avatar image Felix Möhlmann Kritsadakorn K commented ·
Can you upload your model or at least some screenshots of the situation?
0 Likes 0 ·
Kritsadakorn K avatar image Kritsadakorn K Felix Möhlmann commented ·

I can update the simulation model in this answer.

and image settings in the model




0 Likes 0 ·
Show more comments