Mario Mar avatar image
Mario Mar asked Ben Wilson edited

Problem upgrading license server

13:54:59 (flexsim) (@flexsim-SLOG@) ===============================================

13:54:59 (flexsim) (@flexsim-SLOG@) === Reread Info ===

13:54:59 (flexsim) (@flexsim-SLOG@) Reread time: Wed Mar 15 2017 13:54:59 Central Standard Time (Mexico)

13:54:59 (flexsim) (@flexsim-SLOG@) Number of rereads since vendor daemon startup: 1

13:54:59 (flexsim) (@flexsim-SLOG@) Reread mechanism: Manual

13:54:59 (flexsim) (@flexsim-SLOG@) Is TS accessed: No

13:54:59 (flexsim) (@flexsim-SLOG@) TS accessed for feature load: -NA-

13:54:59 (flexsim) (@flexsim-SLOG@) Daemon select timeout (in seconds): 1

13:54:59 (flexsim) (@flexsim-SLOG@) Options file used: licenses\flexsim\flexsim.opt

13:54:59 (flexsim) (@flexsim-SLOG@) License file(s) used: licenses\flexsim\flexsim_server.lic

13:54:59 (flexsim) (@flexsim-SLOG@) ===============================================

13:54:59 (flexsim) ...Finished rereading

13:55:51 (flexsim) UNSUPPORTED: "hcmodule" (PORT_AT_HOST_PLUS ) L00550566@ccmxenapp02 (No such feature exists. (-5,346))

13:55:57 (flexsim) UNSUPPORTED: "hcmodule" (PORT_AT_HOST_PLUS ) L00550566@ccmxenapp02 (No such feature exists. (-5,346:10054 ""))

En el cliente al ejecutar Flexim HC 4.7 se nos despliega:

FlexSim HC 5.1.0
license serverlicensinglmadminnetwork settings
· 4
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Ben Wilson avatar image Ben Wilson ♦♦ commented ·

Hi @Mario Mar,

Thanks for your question. Let's try to figure it out together.

Careful with private information

As we discuss your issue, be sure to never include your license codes on this public question. If we eventually need to, we will start a new private question, rather than share license codes publicly. In any of your responses on this thread, please do not paste your license codes or share any screenshots that include your license codes.

License Files?

Your question title references a license file, however, your FlexSim Account does not have any licenses that use license files. Are you using a license-file based license from some other account? If not, if you are using the licenses in your own account, these are Trusted Storage based licenses and should be activated using flexsimserveractutil.exe.

lmadmin vs lmtools?

Please provide more detailed information regarding the following:

  • What operating system are you using? Is it a VM or installed on the bare metal?
  • lmadmin or lmtools?
  • Did you download the latest (there have been updates to documentation as recently as today, but the major files were last updated Feb 2)
  • Is this an upgrade? Was it working previously?
  • What is the current state of the server? Can you share any screenshots? Does lmadmin or the lmtools-based license service successfully start?
  • What you have tried so far to fix the problem?
  • plus any other information you think could be helpful in our understanding of the issue

If you feel that any of this information should remain private, please start a new, private question.

Links to Documentation

If you're upgrading your license server from a previous version, you'll want to start with the 2017 Migration Guide.

If it is a new license server installation, or you have completed the steps in the 2017 migration guide, go through the steps in the License Server Installation Instructions.

If you are using lmtools to host your licenses, you will also need FlexSim's lmtools guide.

0 Likes 0 ·
Mario Mar avatar image Mario Mar commented ·

seguimos el documento de 2017 Mitration guide y license server installation instrucions y aún tenemos problemas, te comparto algunas imágenes de la configuración del servidor de licencias, así como el error que se registra en el log, y una imagen del error que se muestra en un cliente al acceder al software

En el cliente al ejecutar Flexim HC 4.7 se nos despliega:

Al ejecutar Flexsim 7.1.4 no nos marca error, sólo vemos que el tipo de licencia que indica es “Express”.

0 Likes 0 ·
0xrea.png (29.5 KiB)
dtmfs.png (60.6 KiB)
w58a8.png (35.3 KiB)
Mario Mar avatar image Mario Mar commented ·

This is a virtual machine with Windows 2008 R2 server 64 bit in WMware 6.0, we use with administrator settings

0 Likes 0 ·
Ben Wilson avatar image Ben Wilson ♦♦ Mario Mar commented ·

@Mario Mar,

What about all the suggestions in my previous response. Does everything look correct?

Perhaps it would be good to schedule a remote meeting where I could look at your server configuration? I don't speak Spanish, but we could invite our Mexican partner to be on the call with us. @Jorge Toucet

0 Likes 0 ·

1 Answer

Ben Wilson avatar image
Ben Wilson answered Ben Wilson edited

@Mario Mar,

Thank you for the additional information.

Your screenshot of the lmadmin dashboard shows only the generic "serverfeature", and none of the other features that go along with a FlexSim license. This indicates that lmadmin is not currently hosting your licenses.

Please check the following:

Licenses activated and enabled

In flexsimserveractutil.exe, go to Tools>View License Rights. Are your licenses listed? Are the Trust Flags FULLY TRUSTED? Is the Status ENABLED?

Up-to-date lmadmin

You can check your lmadmin version by going to the Administration section, System Information tab, and looking at the release version. It should be 11.14.0:

Up-to-date licensing service

Did you completely remove the old FlexNet Licensing Service, as specified in the 2017 Migration Guide?

You can check your version of the FlexNet Licensing Service. Go to Windows Services and find the FlexNet Licensing Service in the list:

I have highlighted both 32 and 64 bit versions. You may only have one of the versions, which is usually fine. If you look at the properties of both those files, you can see where the actual .exe is located. Browsing to that location, you can view the properties of the .exe:

Make sure that both .exe files (you may only have one of the versions, which is usually fine) are version or higher, and digitally signed August 15, 2016 or later:

If your version is older, you need to uninstall these services and install the latest versions. Instructions to remove these older services are found in the 2017 Migration Guide. You may need to manually remove the .exe files associated with these services, before using flexsimserveractutil.exe to install the latest versions (see comment below).

lmadmin running with proper permissions

Did you specify for lmadmin to Log on as a Local System Account:

Additional System Information

If everything above is correct, if your licenses appear in flexsimserveractutil.exe, if everything is configured correctly and the proper version, then we still need more information.

  • What is your operating system?
  • Is it a virtual machine? If so, what hypervisor are you using? What version?
  • Have you tried setting lmadmin's Log On setting as a different user, perhaps with even higher privileges?

fullytrusted.png (4.3 KiB)
lmadminlogon.png (48.7 KiB)
· 2
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Ben Wilson avatar image Ben Wilson ♦♦ commented ·

Hi @Mario Mar,

Were you able to get your license server working? If so, please let us know more about the problem and the solution, so that others in the community can learn from your experience.

If you are still trying to get it to work, let us know and we'll continue to gather info and try to figure it out.

0 Likes 0 ·
Ben Wilson avatar image Ben Wilson ♦♦ commented ·

Up-to-date licensing service was the issue here. There was an older version of the FlexNet Licensing Service installed. After using the command line to

sc delete "FlexNet Licensing Service"

and then using flexsimserveractutil.exe to install the latest version, it kept reinstalling the old version. The key was to delete/rename the old FNPLicensingService.exe file so that it wouldn't automatically reinstall.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.