question

Jyrg R avatar image
0 Likes"
Jyrg R asked Jyrg R commented

MTBF crashes AGV simulation

When adding MTBF to an AGV simulation the simulation always crashes after a while during load or unload operation

Attached is a simple example where this happens. If the speed in the simulation is increased it happens very fast.

exception: Exception Caught in FlexSimObject::resume(int id, int stateprofile DEFAULTZERO) object: /TaskExecuter1
exception: Exception Caught in resumeobject(treenode involved, int id)
exception: Exception Caught in ObjectFunction200__project_exec_commandlist_resumeobject_node object: MAIN:/project/exec/commandlist/resumeobject/node i: MAIN:/project/exec/commandlist/resumeobject/node class: MAIN:/project/exec/commandlist/resumeobject/node


How can this be avoided?


MTBF_FAILURE.fsm

FlexSim 20.2.0
agvflexsim 20.2.0mtbf
mtbf-failure.fsm (33.1 KiB)
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

1 Answer

·
Phil BoBo avatar image
0 Likes"
Phil BoBo answered Jyrg R commented

This looks like a bug in the AGV Network handling offset travel. I'll add a case to the dev list.

To work around the issue for now, you can change the following setting on your AGV from "Use navigator for offset travel" to "Do not travel offsets for load/unload tasks":


1598031334441.png (167.8 KiB)
· 1
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Thanks!

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.