Chris Ligetti avatar image
Chris Ligetti asked michel.torbey commented

Flexsim crashing on launch

Flexsim keeps crashing when attempting to launch the software. When debugging in VS, I get the following exception:

Unhandled exception at 0x0000000076E281ED (ntdll.dll) in flexsim.exe: 0xC0000005: Access violation writing location 0x00000000001C0CD8. If there is a handler for this exception, the program may be safely continued.

This occurred after one of my models caused Flexsim to crash. I would like to try and debug what is causing the model to crash, but now I can't even open Flexsim!

FlexSim 17.0.0
flexsim crashing
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

1 Answer

Ben Wilson avatar image
Ben Wilson answered michel.torbey commented

@Chris Ligetti,

Since it appears that something about your FlexSim installation has become corrupted, you might try the suggestions listed on this post regarding problems installing or starting FlexSim.

Based on your description, where your FlexSim installation had once been working, but then due to something in the model some problems have developed, I would start with the suggestion detailing removal of your prefs.t file. It's possible it was corrupted as FlexSim crashed, and now as FlexSim starts and reads in your preferences, there is a problem, and it keeps crashing.

It may also be good to completely uninstall your 17.0.0 installation and go with the latest bugfix in the 17.0 branch, currently at version 17.0.4. (We always recommend being on the latest bugfix release, so this is just a good idea in general anytime).

If the crashing persists, try some of the other suggestions there in the linked post, and let us know if you are able to get FlexSim to open on its own without a model file.

Once you get to that point, then we can look into the model crashes, as needed.

· 9
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

michel.torbey avatar image michel.torbey commented ·

@Ben Wilson Hello Ben,

Since you last update, I am not able to open any flexsim model, even the empty new ones.

I have checked your post and performed everything.

What can i do? I even uninstalled all flexsim versions and installed 2016 & 2017 and it still doesn't work.

Best regards

0 Likes 0 ·
Ben Wilson avatar image Ben Wilson ♦♦ michel.torbey commented ·


FlexSim has worked successfully on your computer in the past, but then after installing an updated version, FlexSim doesn't work?

Here some steps you could try:

  1. Use Windows Add/Remove Programs to completely uninstall all versions of FlexSim
  2. Remove all FlexSim folders from your %AppData% directory
  3. Remove all FlexSim folders from your %ProgramData% directory
  4. Reboot
  5. Perform all Windows updates
  6. Update your graphics driver
  7. Reboot
  8. Now your computer is completely clear of previous FlexSim installations, and is fully patched and updated
  9. Downloading the latest bugfix release of FlexSim
  10. Start the installation by right-clicking the installer and choosing to Run as Administrator
  11. Can you start FlexSim?
  12. Can you start a new model?
  13. Can you open a saved model? If not, it may be a problem with the model. We can help you debug this issue if you post your model, to a new question, please. Make it private if necessary.
0 Likes 0 ·
michel.torbey avatar image michel.torbey Ben Wilson ♦♦ commented ·

@Ben Wilson thank you for your fast answer.

However, I did all the steps you mentioned, and i am trying to open an empty model and flexsim is crashing right away.

Please see the photo attached.sans-titre.png

0 Likes 0 ·
sans-titre.png (56.7 KiB)
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.