Matthew Gillespie avatar image
Matthew Gillespie posted Jordan Johnson commented

FlexSim 2022 Beta available

FlexSim 2022 Beta is now available. (Updated November 23)

To get the beta, log in to your account at, then go to the Downloads section, and click on More Versions. It will be at the top of the list.

The More Versions button does not appear when logged in as a guest account. Subsequently the beta is available only to licensed accounts and accounts that have a license shared with them. Learn more about downloading the best version of FlexSim for your license here.

If you have bug reports or other feedback on the software, please email [email protected] or create a new idea in the Development space.

FlexSim 22.0.0 Release Notes

  • Added several new features to the Experimenter including:
    • Experimenter can define and run multiple different jobs.
    • Experimenter results are stored in a database file.
    • Additional replications of a scenario can be run without needing to rerun previous replications.
    • Improved visuals for status of replications.
  • Added a Reinforcement Learning tool.
  • Added Label charts.
  • Added Tracked Variable charts.
  • Standardized charts created by Pin buttons.
  • Added sort options to table views.
  • Updated MTBF/MTTR time fields to show unit conversion options.
  • Added InObjectsInternal and OutObjectsInternal properties to the Visual Tool class.

Backwards Compatibility Note:

The following changes may slightly change the way updated models behave.

  • Deprecated the optquest() command. It no longer executes any logic when called. The associated OPT_* macros have been removed. FlexSim now interacts with OptQuest through the Optimization Job object.
  • Changed the default query handlers that deal with the Experimenter in MAIN:/project/exec/globals/serverinterface/queryhandlers. Custom applications that create web queries may need to be updated.

Process Flow

  • Added Process Flow Activity Statistics charts.
product announcementbeta
· 24
5 |100000

Up to 12 attachments (including images) can be used with a maximum of 23.8 MiB each and 47.7 MiB total.

Clair A avatar image Clair A commented ·

We can't install it.



I think there is an issue with the installer. On the website it says that the installer size is 629 MB:


But once the download is complete, the file size is 434 MB:


1 Like 1 ·
1636462787686.png (32.9 KiB)
1636462803482.png (15.9 KiB)
1636462851319.png (17.0 KiB)
1636462943999.png (4.7 KiB)
Phil BoBo avatar image Phil BoBo ♦♦ Clair A commented ·
0 Likes 0 ·
Ben Wilson avatar image Ben Wilson ♦♦ Clair A commented ·

@Clair A,

I have re-uploaded the installer.

I just tested a new download and installation with this updated upload, and everything worked well for me.

Please try again and let us know of any problems.

0 Likes 0 ·
Clair A avatar image Clair A Ben Wilson ♦♦ commented ·

Thanks @Ben Wilson , with the updated installer it works well, I have completed the installation.

0 Likes 0 ·
Maryam H2 avatar image Maryam H2 commented ·

@Matthew Gillespie I see nothing happens when I hit that help button for "Tracked Variable", "Label Chart", and "Process flow activities". Is there any documentation for those charts that I can use?

0 Likes 0 ·
Matthew Gillespie avatar image Matthew Gillespie ♦♦ Maryam H2 commented ·

@Maryam H2 Some of the documentation for the newest features is still under construction. It should be up soon though.

0 Likes 0 ·
Ralf Gruber avatar image Ralf Gruber ♦ commented ·

It seems a 22.1 OptQuest license is not recognized by the beta, while a 22.2 works just fine.

Is that a bug?

0 Likes 0 ·
Phil BoBo avatar image Phil BoBo ♦♦ Ralf Gruber ♦ commented ·

What does "is not recognized by the beta" mean?

Seems to be working fine to me:


0 Likes 0 ·
1636648275806.png (298.8 KiB)
Ralf Gruber avatar image Ralf Gruber ♦ Phil BoBo ♦♦ commented ·


In the "Jobs" tab I can add an Experiment only, but not an Optimization. If I load an old OptQuest model, I can duplicate the Optimization, but still not add one. Menu just shows "Experiment".


However, it now does not work with the updated 22.2 license either.

Originally I tried 22.1 based upon @Felix Möhlmann not being able to use the Optimizer as well. When I upgraded to 22.2, it worked, but now it does not anymore...or do I do something fundamentally wrong? Should I not even in a blank model be able to add an Optimization to the Experimenter?


0 Likes 0 ·
optquest.png (78.7 KiB)
Show more comments
Lars Christian J2 avatar image Lars Christian J2 commented ·

I am not able to install stable-baseline3. It says it depends on torch. What should I do? I have attempted to use Conda, as it is better at resolving package dependencies, but I am not able to activate Conda from with Visual Studio.



0 Likes 0 ·
1637138137161.png (17.4 KiB)
Jordan Johnson avatar image Jordan Johnson ♦♦ Lars Christian J2 commented ·

I had this problem when I was using python 3.10; I couldn't get torch to build with that version. When I switched to 3.8 or 3.9, it worked fine. I also read online that it can happen if you are using the 32-bit version of python, when I was trying to figure out what was wrong.

I also used Visual Studio Code, rather than Visual Studio. The documentation has been updated for that case. If you want to use Conda, I'd recommend that option. I was able to use Conda within VS Code (which is not part of the documentation); as long as you specify a python version when you create a Conda virtual environment, VS Code will let you pick that environment as your default interpreter. I learned that on this page, which may have other helpful information for you:

1 Like 1 ·
Clair A avatar image Clair A Jordan Johnson ♦♦ commented ·

Hi @Jordan Johnson, some of our users reported that they were blocked when following the Reinforcement Learning tutorial. The tutorial says:

Download and install VS Code, its Python extension, and Python 3


But it is not precised which version of Python 3 needs to be installed. If you install for example Python 3.11.2, you will be blocked later in the tutorial at the step where stable_baselines3 needs to be installed (, because there is no compatible version of stable_baselines3 with Python 3.11.2.

Could you please add a warning note in the tutorial here:


To precise that this tutorial was initially designed to work with Python 3.8. And maybe add the download link if needed:

+ 1 comment that if the user installs Python 3.10 or later, he will not be able to complete this tutorial, because some provided packages in the tutorial are not compatible with Python versions that were released after this tutorial was created.

0 Likes 0 ·
1680536586015.png (9.0 KiB)
Show more comments
David Seo avatar image David Seo commented ·

I can't install the new Nov 15 version beta. The program looks like to have a problem.

The manual installation program is same also.

0 Likes 0 ·
Phil BoBo avatar image Phil BoBo ♦♦ David Seo commented ·
0 Likes 0 ·
Ben Wilson avatar image Ben Wilson ♦♦ David Seo commented ·

@David Seo I tested a new download of the .exe installer. It was able to successfully upgrade my previous 22.0 beta installation. I then used it to uninstall the beta, and reinstall. It was successful in all 3 instances.

I then tested a new download of the .msi installer. Here I found problems. I have since re-uploaded the .msi. Since then I have used a new download from my account to uninstall and install, and both are working.

Let us know if you encounter any issues.

0 Likes 0 ·
David Seo avatar image David Seo Ben Wilson ♦♦ commented ·

Thank you @Ben Wilson

Yes. I installed msi program not exe. It had a problem.

I have done it again using new msi you uploded newly.

It was installed and run without any problem.


0 Likes 0 ·
Show more comments
Show more comments



matthew.gillespie contributed to this article